Mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olaf Flebbe <..@oflebbe.de>
Subject Re: Spark 2
Date Sun, 31 Jul 2016 09:44:35 GMT
Hi,

spark 2.0.0 compiles out of the box in bigtop-trunk, but packaging fails.

Did you honor the instructions to setup your compile environment to compile within bigtop?
https://cwiki.apache.org/confluence/display/BIGTOP/How+to+build+Bigtop-trunk

Either run puppet or use the recommended way to build within a docker container:

docker run -v `pwd`:/ws bigtop/slaves:trunk-centos-7 bash -l -c 'cd /ws ; gradle scala-pkg'

Olaf

> Am 30.07.2016 um 02:50 schrieb <chris@bigstream.co> <chris@bigstream.co>:
> 
>  Has anyone gotten spark 2 to build in Bigtop? I've changed the version in the BOM but
there's a maven error in the compilation where it says
> 
> [INFO] Using zinc server for incremental compilation
> [error] Required file not found: scala-compiler-2.11.8.jar
> [error] See zinc -help for information about locating necessary files
> 
> even though a couple lines above it says it downloaded scala-compiler-2.11.8.jar
> 
> Downloaded: https://repo1.maven.org/maven2/org/scala-lang/scala-compiler/2.11.8/scala-compiler-2.1
> 1.8.jar
> 
> Any ideas?


Mime
View raw message