Mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harish JP <...@hortonworks.com>
Subject Re: Tez UI unable to display DAG
Date Mon, 12 Dec 2016 02:24:39 GMT
Are you using ATS v1.5 or ATS v1? The tez app seems to have initialized with ATS v1 and the
server seems to be of ATS v1.5.

Set: tez.history.logging.service.class=org.apache.tez.dag.history.logging.ats.ATSV15HistoryLoggingService
and try again.

—
Thanks,
Harish

On 10-Dec-2016, at 12:46 AM, Madhusudan Ramanna <m.ramanna@ymail.com<mailto:m.ramanna@ymail.com>>
wrote:

Hello Tez folks,

Tez UI (0.8.4) is able to communicate with RM and display application ids and completion status.
 It is however not displaying DAG or config information.

http://host/ws/v1/cluster/apps/application_1481155336218_0289?_=1481308956420 (RM API)
returns
{
"app": {
"id": "application_1481155336218_0289",
"user": "apxqueue",
"name": "snipped name",
"queue": "dev",
"state": "FINISHED",
"finalStatus": "SUCCEEDED",
"progress": 100.0,
"trackingUI": "History",
"trackingUrl": "http://host:8088/proxy/application_1481155336218_0289/tez-ui/#/tez-app/application_1481155336218_0289",
"diagnostics": "",
"clusterId": 1481155336218,
"applicationType": "TEZ",
"applicationTags": "",
"startedTime": 1481247775060,
"finishedTime": 1481247839054,
"elapsedTime": 63994,
"amContainerLogs": "host/node/containerlogs/container_1481155336218_0289_01_000001/apxqueue",
"amHostHttpAddress": "host:8042",
"allocatedMB": -1,
"allocatedVCores": -1,
"runningContainers": -1,
"memorySeconds": 331219,
"vcoreSeconds": 132,
"preemptedResourceMB": 0,
"preemptedResourceVCores": 0,
"numNonAMContainerPreempted": 0,
"numAMContainerPreempted": 0,
"logAggregationStatus": "SUCCEEDED"
}


http://host:8188/ws/v1/timeline/TEZ_DAG_IDlimit=9007199254740991&primaryFilter=applicationId%3Aapplication_1481155336218_0289&_=14
81308956444
(Timeline server)

returns
{"entities":[]}

I don't see any errors in Tez logs about Time line server setup.

>>>>>>
2016-12-09 01:25:42,097 [INFO] [main] |web.WebUIService|: Tez UI History URL: http://host/tez-ui/#/tez-app/application_1481155336218_0243
2016-12-09 01:25:42,097 [INFO] [main] |history.HistoryEventHandler|: Initializing HistoryEventHandler
withrecoveryEnabled=true, historyServiceClassName=org.apache.tez.dag.history.logging.ats.ATSHistoryLoggingService
2016-12-09 01:25:42,440 [INFO] [main] |impl.TimelineClientImpl|: Timeline service address:
http://host:8188/ws/v1/timeline/
2016-12-09 01:25:42,440 [INFO] [main] |ats.ATSHistoryLoggingService|: Initializing ATSHistoryLoggingService
with maxEventsPerBatch=5, maxPollingTime(ms)=10, waitTimeForShutdown(ms)=-1, TimelineACLManagerClass=org.apache.tez.dag.history.ats.acls.ATSHistoryACLPolicyManager
2016-12-09 01:25:42,535 [INFO] [main] |impl.TimelineClientImpl|: Timeline service address:
http://host:8188/ws/v1/timeline/
<<<<<<

Some log from DAG yarn logs:

2016-12-09 01:25:43,337 [INFO] [main] |history.HistoryEventHandler|: [HISTORY][DAG:dag_1481155336218_0243_1][Event:DAG_SUBMITTED]:
dagID=dag_1481155336218_0243_1, submitTime=1481246743061

We Don't see any error logs in timeline server as well.  What could be happening here ?

We switched out Tez UI with 0.8.4 with 0.9.0 (commit: c07ec7).   However we saw errors like
these on timeline server:
java.io.IOException: History file for application application_1481155336218_0206 is not found

We don't see this error while using Tez UI 0.8.4

Any pointers are greatly appreciated

thank you,
Madhu








Mime
View raw message